خانه / آموزش های اختصاصی / آموزش متنی محدودیت حجمی برای کاربران رایگان Hotspot

آموزش متنی محدودیت حجمی برای کاربران رایگان Hotspot

hotspot-wifi

آموزش متنی محدودیت حجمی برای کاربران رایگان hotspot

۱- برنامه winbox را اجرا نمایید.

۲- به میکروتیک متصل شوید.

۳- ابتدا در قسمت

IP>HOTSPOT>USER PROFILES>ADD

یک پروفایل با نام FreeUser ایجاد کنید توجه کنید که حتما با همین نام بسازید چون در اسکریپت مورد نظر بهش نیاز داریم در اینجا اگر مایل باشید میتونید محدودیت سرعت در Rate limit برای کاربران trial ایجاد کنید.

مثال محدودیت سرعت 

روش اول

برای سرعت آپلود و دانلود ۱۲۸Kb

Rate limit=128000

۱۲۸+۰۰۰=۱۲۸۰۰۰ ——>128kB upload&download

روش دوم

برای سرعت ۲۵۶Kb دانلود و سرعت ۱۲۸kb آپلود

Rate Limit=128000/256000

۱۲۸+۰۰۰=۱۲۸۰۰۰ ——>128kb upload

۲۵۶+۰۰۰=۲۵۶۰۰۰ ——>256kb download

۴- بعد برای اینکه چک کنیم هر کاربر چقدر مصرف کرده و اینکه اگر از حد مورد نظر بیشتر استفاده کرده یوزرش بسته بشه از اسکریپت استفاده میکنیم.

۵- اسکریپت زیر را در مسیر زیر اضافه نمایید.

System—>Scripts—–> + or (Add)

نام این اسکریپت را limitdata قرار دهید.

سپس اسکریپت را در source کپی نمایید

میزان دانلود نیز در

:local downloadlimitmb “5000

۵۰۰۰=۵۰ MB

For 10 MB Put 10000

مشخص میشه که ۵۰ مگ هست.

#Set your dowload limit in MegaBYTES!
:local downloadlimitmb "5000"


### You will not need to edit anything below this line ###
:local downloadlimit  [($downloadlimitmb  * 1000)]
:local counter
:local datadown
:local username
:local macaddress
:foreach counter in=[/ip hotspot active find ] do={
:set datadown [/ip hotspot active get $counter bytes-out]
:if ($datadown>$downloadlimit) do={
:set username [/ip hotspot active get $counter user]
:set macaddress [/ip hotspot active get $counter mac-address]
/ip hotspot user remove [/ip hotspot user find where name=$username]
/ip hotspot user add name=$username limit-bytes-out=$downloadlimit mac-address=$macaddress profile=FreeUser
/ip hotspot active remove $counter
:log info "Force logout on user: $username - Reached download quota"
}}

دانلود کد

۶- برای اینکه همه کاربرانی که محدودیت دانلود روشون اعمال شده ازبین برن، از  اسکریپت زیر استفاده می کنیم.

۷-  اسکریپت زیر را در مسیر زیر اضافه نمایید.

System—>Scripts—–> + or (Add)

نام این اسکریپت را clearusers قرار دهید.

:log info "Checking Users"
:local counter


:foreach counter in=[/ip hotspot user find profile="FreeUser" ] do={
/ip hotspot user remove $counter
}

دانلود کد

۸- حال باید scheduler ایجاد کنیم که بسته به نیاز شما هر مدت زمان مشخص اسکریپت ها اجرا شوند.

اسکریپت اول هر ۱۰ ثانیه میتونه خوب باشه و برای اسکریپت دوم بستگی داره که می خواهید این محدودیت تا چه مدت پایدار باشد.

 

۹- scheduler زیر را در مسیر زیر اضافه نمایید.

برای اسکریپت ایجاد محدودیت

System—> scheduler —-> + or (Add)

Name= Datalimit

Start Time= startup

Interval: 00:00:15

On Event = limitdata

Policy = Full

برای اسکریپت رفع محدودیت

System—> scheduler —-> + or (Add)

Name= ClearUsers

Start Time= startup

Interval: 12:00:00 or  ۱d 00:00:00 or …

On Event = ClearUsers

Policy = Full

آموزش به پایان رسید.

موفق باشید.

درباره ی آپلینوس

عاشق دنیای آی تی

۱۶ دیدگاه

  1. سلام خسته نباشید
    آیا استفاده از هات اسپات برای کابران لوکال مناسب هست یا خیر؟
    آموزشی درباره راه اندازی رادیوس سرور و استفاده از نام کاربری و پسورد کاربران اکتیو دایرکتوری برای اتصال به هات اسپات میکروتیک دارید ؟

    • باسلام و درود

      بله, از هات اسپات می توانید برای تمام کاربران استفاده نمایید.

      آموزش راه اندازی رادیوس سرور هات اسپات در سایت موجود است.

      آموزش اتصال کاربران اکتیو دایرکتوری به هات اسپات را بررسی و در سایت قرار خواهیم داد.

      باتشکز

  2. با سلام
    آیا در هات اسپات یا سایر بخش های یوزم منیجر میشه یه لیست آماده یوزر و پسورد برای لوگین رو مثلا از فایل تکست یا اسکریپت به سیستم اضافه کرد؟ میشه آموزش اون رو بذارید؟

  3. با سلام من دنبال اسکریپت (راه حلی ) برای اینکه بتوانم یک سری از یوزرهای(هات اسپات)را در ساعات معینی فعال کنم هستم . مثلا user1 در ساعت 8 تا 16 و user2 از ساعت 16 تا 12 شب . البته فکر کنم این کار در یوزر منیجر امکان پذیر باشد .من چون smips هستم usrmanger ندارم لطفا کمک کنید .آیا میتوانم به کمک اسکریپت مشکلم را حل کنم .

    • باسلام

      می توانید از Scheduler در میکروتیک به دو طریق استفاده نمایید:

      1-ابتدا به یوزرهای مورد نظر آی پی خاص بدهید و توسط On Event در Scheduler تمامی Nat یوزر ها را در زمان های خاص فعال یا غیر فعال نمایید.
      2-توسط Scheduler یوزر های هات اسپات را در زمان های خاص فعال یا غیر فعال نمایید.

      در On Event در تب Scheduler باید مسیری که در ترمینال انجام می دهید وارد نمایید تا در زمان های خاص دستور شما انجام شود.

      باتشکر

  4. سلام وقت بخیر
    این اسکریپت که نوشتین بعد اینکه محدودیت دانلود رو اعمال میکنه و کاربرها رو از حالت فعال خارج میکنه.حتی با ریست کردن دستی شمارنده ها.اجازه اتصال دئباره بهشون نمیده!
    حتی من پروفایل کاربر رو هم عوض کردم باز تاثیر نداشت و اجازه لاگین مجدد به همون یوزر رو نمیده!
    میشه راهنمایی بکنید چیکار کنم؟
    یا من جایی اشتباه کردم؟

    ————————

    دوست عزیز شرمنده.
    مشکل من حل شد.
    من دقت نمیکردم این اسکریپت بعد اینکه کاربر رو از کار مینداخت رمز عبورش رو ریسیت میکنه و خالی میکنه.
    دوباره با تنظیم رمز عبور مشکلم حل شد.
    تشکر

  5. سلام خسته نباشید برای ایجاد هات اسپات حتما باید کارت شبکه وایرلس داشته باشیم یا نه؟؟؟؟؟

  6. سلام – وقت بخیر
    با تشکر از آموزش خوبتون
    چطور میشه در میکروتیک تنظیمی اعمال کرد که بدون اینکه کاربران صفحات اسپات رو ببینن ، بتونن به اینترنت وصل شن با این شرط که مثلا 50 مگ و 20 دقیقه بیشتر نتونن استفاده کنن؟

    • با سلام

      این کار از لحاظ فنی قابل انجام نمی باشد زیرا تا کاربر وارد نشود نمی توان محدودیتی اعمال نمود.

      سناریو پیشنهادی:

      کد صفحه هات اسپات را پاک و سپس لینک ورود کاربر مهمان را وارد نمایید و سپس کد را توسط کد های html تنظیم نمایید که کاربر را بصورت خودکار پس از باز شدن یک سایت به لینک ورود کاربر مهمان هدایت کنید و کاربر بصورت خودکار و بدون دیدن صفحه ای وارد شود.

      لینک آموزش این سناریو (بزودی)

      باشتکر

  7. با درود
    چطور ميتوان با ساخت يك كاربر به نام test و رمز عبور test تنظيماتي اعمال كرد كه حداكثر ٢٠ كلاينت به طور هم زمان با آن نام كاربري وارد شوند و بتوانند هر كدام ٢٠ دقيقه و يا حداكثر ٥٠ مگابايت از اينترنت استفاده كنند و پس از اتمام بسته ي آنها تا ٢٤ ساعت نتتوانند در شبكه وارد شوند.
    من اين سناريو را پياده سازي كردم فقط در اينجا تنها مشكلي كه دارم اين است كه با خارج كردن از ssid و ورود مجدد به شبكه هات اسپات با نام كاربري و رمز تايين شده ميتتوان از حجم تايين شده مجددا استفاده كرد.
    لطفا راهنمايي بفرماييد.
    با سپاس.

    • با سلام

      1- از IBSng می توانید برای اکانتینگ استفاده نمایید.

      2- در تنظیمات HotSpot , زمان cookie کاربر را افزایش دهید.
      و مقدار Address per mac را 1 قرار دهید.
      در DHCP Server مقدار Lease Time را افزایش دهید.

      باتشکر

  8. ضمن تشکر از آموزشهای خوبتون میخواستم بدون چطور میشه گفت هر کاربر 10 دقیقه بیشتر استفاده نکنه؟

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

قالب وردپرس